PAT A 1095. Cars on Campus (30)

题目

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each "in" record is paired with the chronologically next record for the same car provided it is an "out" record. Any "in" records that are not paired with an "out" record are ignored, as are "out" records not paired with an "in" record. It is guaranteed that at least one car is well paired in the input, and no car is both "in" and "out" at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09


比较肉的模拟类问题,知道怎么去除无效的数据,直接模拟就可以了

有效的配对是指紧挨着的两个in和out,

也就是说连续的多个in取最后一个为有效,连续多个out取第一个为有效,

最后如果有in没有被匹配,则应该放弃相应的记录


代码:

图省事,写得比较烂,实际是不需要对数据进行那么多的复制操作的

#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <map>
using namespace std;

const int LIMIT=24*3600;

struct car	//车结构
{
	int id,time,in_out;	//车的id,动作时间,进出动作
	car(int i=0,int t=0,int io=0):id(i),time(t),in_out(io){}
};

int to_time(string s);	//将字符串表示的时间转换为时间
bool cm(const car &c1,const car &c2);	//时间排序

int main()
{
	int n,k;
	cin>>n>>k;

	map<string,int> name_to_id;	//车牌到id转换
	vector<string> id_to_name(1,"");	//id到车牌转换
	int id=0;
	vector<car> data;	//存储的数据
	car tempc;			//临时输入数据
	string sn,st,sf;
	for(int i=0;i<n;i++)	//输入所有数据
	{
		cin>>sn>>st>>sf;
		if(name_to_id[sn]==0)
		{
			name_to_id[sn]=++id;
			id_to_name.push_back(sn);
		}
		tempc.id=name_to_id[sn];
		tempc.time=to_time(st);
		if(sf=="in")
			tempc.in_out=1;
		else
			tempc.in_out=0;
		data.push_back(tempc);
	}
	sort(data.begin(),data.end(),cm);	//时间排序

	vector<vector<car>> use(id+5);	//各个id的车的有效记录
	vector<int> total(id+5,0);	//各个id的车的总泊车时间
	for(int i=0;i<data.size();i++)	//按id划分,去除不必要数据
	{
		if(data[i].in_out==1)
		{
			if(!use[data[i].id].empty()&&use[data[i].id].back().in_out==1)
				use[data[i].id].pop_back();
			use[data[i].id].push_back(data[i]);
		}
		else
		{
			if(!use[data[i].id].empty()&&use[data[i].id].back().in_out==1)
			{
				total[data[i].id]+=data[i].time-use[data[i].id].back().time;
				use[data[i].id].push_back(data[i]);
			}
		}
	}
	for(int i=0;i<use.size();i++)
	{
		if(!use[i].empty()&&use[i].back().in_out==1)
			use[i].pop_back();
	}

	int max=0;	//最长泊车时间
	vector<string> max_name;	//最长泊车时间的车辆的车牌集合
	for(int i=1;i<=id;i++)	//统计
	{
		if(!use[i].empty()&&total[i]==max)
			max_name.push_back(id_to_name[use[i].front().id]);
		else if(!use[i].empty()&&total[i]>max)
		{
			max=total[i];
			max_name.clear();
			max_name.push_back(id_to_name[use[i].front().id]);
		}
	}
	sort(max_name.begin(),max_name.end());

	data.clear();	//清除原数据,重新取所有有效记录,并排序
	for(int i=1;i<=id;i++)
		for(int j=0;j<use[i].size();j++)
			data.push_back(use[i][j]);
	sort(data.begin(),data.end(),cm);

	int pos=0,count=0,next;	//取到的位置,当前学校中的车辆数,下个请求时间
	for(int i=0;i<k;i++)	//统计输出
	{
		cin>>st;
		next=to_time(st);
		while(pos<data.size()&&data[pos].time<=next)
		{
			if(data[pos].in_out==1)
				count++;
			else
				count--;
			pos++;
		}
		printf("%d\n",count);
	}
	for(int i=0;i<max_name.size();i++)
		cout<<max_name[i]<<" ";
	printf("%02d:%02d:%02d",max/3600,max%3600/60,max%60);

	return 0;
}

int to_time(string s)
{
	int time=0;
	time+=(s[0]-'0')*10*3600;
	time+=(s[1]-'0')*3600;
	time+=(s[3]-'0')*10*60;
	time+=(s[4]-'0')*60;
	time+=(s[6]-'0')*10;
	time+=(s[7]-'0');
	return time;
}

bool cm(const car &c1,const car &c2)
{
	return c1.time<c2.time;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值