1042 Shuffling Machine (20 分)

原题目:

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

结尾无空行

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H

 

题目大意:有54张牌,编号为1~54,初始按编号从小到大排列。这些牌按初始排列给定花色,从左到右为13张S,13张H,13张C,13张D,2张J,接下来执行一操作,将牌的位置改变为指定位置,这样的操作执行k次。求最好的排列结果。

分析:change用来存放洗牌数组。end用来存放最终数组。考虑到多次洗牌,用temp来存放每次执行操作前的牌序。

输出是花色+牌号。对应关系是:S对应1-13,H对应14-26,C对应27-39,D对应40-52, J对应53-54

牌号计算用%13取余操作。注意13的倍数取余是0,而13号要求输出S13,所以先判断下是否13倍数,是的话就不用取余。

花色用/13操作,还是那个问题,我们希望得到1-13 除13得到0,对应huase[0]的花色。而13/13得到1,所以可以将序号减1再/13。

#include<bits/stdc++.h>
using namespace std;


int main(){
    char huase[5]{'S','H','C','D','J'};
    int change[60],temp[60],end[60];
    for(int i=0;i<=54;i++){//初始化temp、end 数组
    temp[i]=i;
    end[i]=i;
    }
    //初始化change 变换数组
    int K;
    scanf("%d",&K);
    for(int i=1;i<55;i++){
    scanf("%d",&change[i]);
    }
    
    while(K--){
        for(int i=0;i<55;i++){
        temp[i]=end[i];
        }//暂存变换过程中数组
        for(int i=0;i<55;i++){
        end[change[i]]=temp[i];
        }//变换
    }
    //输出

    for(int i=1;i<=54;i++){
        printf("%c",huase[(end[i]-1)/13]);
        if(end[i]%13==0) printf("13");
        else printf("%d",end[i]%13);
        if(i<54)printf(" ");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值