C语言动态规划(2)___Maximum sum

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

样例:

#include <stdio.h>
#define max(A,B) ((A) >= (B) ? (A) : (B))
int main()
{
	int a[50010],b[50010],c[50010],d[50010],i,n,j,k,N; //a数组放数列.
//b[i]前i个数中最大的子序列和.d[i]表示后i个数中最大的子序列和
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			if(i==0)
				k=c[0]=b[0]=a[0];
			else
			{
				c[i]=max(c[i-1]+a[i],a[i]); //动态规划
				k=b[i]=max(c[i],k);
			}
		}
		for(i=n-1;i>=0;i--)
		{
			if(i==n-1)
				k=d[i]=c[i]=a[i];
			else
			{
				c[i]=max(c[i+1]+a[i],a[i]);  //动态规划
				k=d[i]=max(c[i],k);
			}
		}
		k=-99999;
		for(i=0;i<n-1;i++)
		{
			a[i]=b[i]+d[i+1];
			k=max(a[i],k);
		}
		printf("%d\n",k);
	}
	return 0;
}

简单的一道动态规划题时间复杂度为O(N)


Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.
  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Maximum Sum Increasing Subsequence (最大上升子序列和)问题可以使用动态规划来解决,以下是使用C语言实现的代码: ```c #include <stdio.h> int max(int a, int b) { return a > b ? a : b; } int maxSumIncreasingSubsequence(int arr[], int n) { int i, j, maxSum = 0; int dp[n]; // 初始化dp数组为每个元素自身 for(i = 0; i < n; i++) { dp[i] = arr[i]; } // 动态规划计算最大上升子序列和 for(i = 1; i < n; i++) { for(j = 0; j < i; j++) { if(arr[j] < arr[i]) { dp[i] = max(dp[i], dp[j] + arr[i]); } } } // 找到dp数组中的最大值 for(i = 0; i < n; i++) { if(maxSum < dp[i]) { maxSum = dp[i]; } } return maxSum; } int main() { int arr[] = {1, 101, 2, 3, 100, 4, 5}; int n = sizeof(arr) / sizeof(arr[0]); printf("最大上升子序列和为 %d", maxSumIncreasingSubsequence(arr, n)); return 0; } ``` 输出结果为: ``` 最大上升子序列和为 106 ``` 上述代码中,首先定义了一个 `max` 函数,用于比较两个数中的较大值。然后定义了一个 `maxSumIncreasingSubsequence` 函数,用于计算最大上升子序列和。该函数使用一个一维数组 `dp` 来记录从第一个元素到当前元素的最大上升子序列和。在初始化 `dp` 数组时,将每个元素的值初始化为自身;然后使用两层循环遍历数组,如果当前元素大于前面的元素,则将 `dp[i]` 更新为 `dp[j] + arr[i]` 的较大值;最后在 `dp` 数组中找到最大值即为最大上升子序列和。最后在 `main` 函数中定义一个整型数组 `arr`,并计算其最大上升子序列和并输出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值