nim博弈_______Crazy Calendar( lightoj 1393 )

Description

2011 was a crazy year. Many people all over the world proposed on 11-11-11, married on 11-11-11, some even went through surgery only to have 11-11-11 as their child's birth date. How crazy people can be! Don't they see there is a "20" hidden? Then what to do? A very elegant solution came from ARR, a very famous and funny character - why do we need to follow Christian (or some calls it Gregorian) calendar? Why don't we start our own calendar on the day of marriage? And those who like to celebrate their marriage ceremony too frequent, why don't they declare only 1 day per year. In that fashion they can celebrate their anniversary every day. And may be one minute a year or a second or ... Uh.. getting complex. Let's back to the title. From now, we start to have a new calendar system, "Kisu Pari Na". And we hope to update this calendar on every national contest.

The purpose of this calendar is - we all will try our best to learn something new in every year. For this first year let's learn some combinatory. It reminds me of my first year in college. I faced this problem but could not solve this then. But see how easy it is:

 

 

 

 

 

 

 

 

 

 

 

 

Say you start from upper left cell and want to go to lower right cell. The only restriction is you can only move downward or rightward. How many ways are there? How to solve it? Not that difficult. You have to go two times Down and three times Right (whichever way you try) to reach the goal from the starting cell, right? So the answer is number of ways you can arrange two D (represents Down) and three R (represent Right). 2 same characters and 3 same characters, total 5 characters. So it is:

Or =D+RCR. Easy isn't it?

Ok enough with learning. Now back to problem, given a grid and at each cell there are some coins. Inky and Pinky are playing a game getting inspiration from the above problem. At each turn, a player chooses a non empty cell and then removes one or more coins from that cell and put them to the cell exactly right of it or exactly beneath it. A player can't divide the coins and put one part to right and others to down. Note that, for the cells at the right column the player can't move it to more right, and same for the bottom-most row. So a player can't move coins from the lower right cell. The game will finish when no moves are available and the player who moved last will win. Now inky being very modest asked Pinky to move first. Can you say if Pinky will win if both play perfectly?

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing two integers R C (1 ≤ R * C ≤ 50000), where R denotes the number of rows and C denotes the number of columns of the grid respectively. Each of the next R lines contains C space separated integers denoting the grid. These integers lie in the range [0, 109].

Output

For every test case, output case number followed by "win" if Pinky can win or "lose".

Sample Input

1

2 2

1 1

1 1

Sample Output

Case 1: lose



题意:

有个n*m的棋盘,每个格子有一些石子,两个人轮流行动,每次行动可以任选一个格子的任意个石头(至少大于0)。对于每个石头可以向下移动或者向右移动一格。如果轮到某人行动却无石头可以移动则算输。


分析:

如果该方格中的一个点的坐标与n+m的奇偶性相同,则不需要考虑该点。因为若该点与n+m奇偶性相同,设该点坐标为(i,j)(0<=i<=n,0<=j<=m)则(n+m)-(i+j),即到达终点的步数为偶数,也就是说先手怎么移动后手就怎么移动,先手右后手就下,先手下后手就右,也就是说等于没移动。所以我们只需要考虑与n+m不同的,也就是n+m和i+j一个奇数一个偶数,也就是说,这些点距离终点只需要也只能移动一次,每次可以从一个方格中取任意个石子移动,这就转化为了尼姆博弈中的取石子问题,因为尼姆博弈中可以随意取石子。异或为0为必败态一定会转化为必胜态,异或为1为必胜态可以转化为必败态,具体详见下最基础的尼姆博弈--取石子问题,就ok了。



代码:

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int t,cas=1;
    cin>>t;
    while(t--)
    {
        int r,c,data,ans=0;
        cin>>r>>c;
        for(int i=0; i<r; i++)
        {
            for(int j=0; j<c; j++)
            {
                cin>>data;
                int a=((r+c)-(i+j))%2;
                if(a)
                    ans^=data;
            }
        }
        if(ans)
            printf("Case %d: win\n",cas++);
        else
            printf("Case %d: lose\n",cas++);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值