poj 2096 Collecting Bugs(概率DP)

Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 1756 Accepted: 809
Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

题意

题意有点不好懂。开始读了一阵才懂了。

一个软件有s个子系统,会产生n种bug
某人一天发现一个bug,这个bug属于一个子系统,属于一个分类
每个bug属于某个子系统的概率是1/s,属于某种分类的概率是1/n
问发现n种bug,每个子系统都发现bug的天数的期望。

思路:

读懂题后就凌乱了。感觉好复杂。然后用还是硬着头皮上了。

既然题目涉及到了。n中bug和s个系统。那么久用二维表示看看。

dp[i][j]表示找到i种bug且程序中已经有j个子系统发现bug天数的期望。

然后又想怎么转移呢。

又考虑新的一天发现的bug有4种可能。

1.发现的bug在i中之中并没有增加bug的种类。发现的bug也在j个子系统内也没有增加系统数。

那么dp[i][j]=(dp[i][j]+1)*I*j/(s*n).

2.发现的bug没增加种类但增加了系统数。

那么dp[i][j]=(dp[i][j+1]+1)*I*(s-j)/(s*n).

3.发现的bug增加了种类但没增加系统。

那么dp[i][j]=(dp[i+1][j]+1)*(n-I)*s/(s*n).

4.发现的bug既增加了种类又增加了系统。

那么dp[i][j]=(dp[i+1][j+1]+1)*(n-I)*(s-j)/(s*n).

思路一下子明朗了。

那么dp[i][j]=(dp[i][j]+1)*I*j/(s*n)+(dp[i][j+1]+1)*I*(s-j)/(s*n)+(dp[i+1][j]+1)*(n-I)*s/(s*n)+(dp[i+1][j+1]+1)*(n-I)*(s-j)/(s*n).

那么一整理:

dp[i][j]=(dp[i][j+1]*i*(s-j)+dp[i+1][j]*(n-i)*j+dp[i+1][j+1]*(n-i)*(s-j)+n*s)/(s*n-i*j)。

写完代码后抱着试试看的心态就交了。然后就A了。

看来果断要敢想敢干呀。虽然是水题但是思路就是一步步来的。

详细见代码:

#include <iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
const int maxn=1010;
double dp[maxn][maxn];

int main()
{
    int n,s,i,j;

    while(~scanf("%d%d",&n,&s))
    {
        dp[n][s]=0;
        for(i=n;i>0;i--)
        {
            for(j=s;j>0;j--)
            {
                if(i==n&&j==s)
                    continue;
                dp[i][j]=dp[i][j+1]*i*(s-j)+dp[i+1][j]*(n-i)*j+dp[i+1][j+1]*(n-i)*(s-j)+n*s;
                dp[i][j]/=(s*n-i*j);
            }
        }
        dp[0][0]=dp[1][1]+1;
        printf("%.4lf\n",dp[0][0]);
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值