poj 2376 Cleaning Shifts(贪心)

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9273 Accepted: 2473

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

Source

题意

给你n个区间。[li,ri]问至少需要用到多少区间才能把[1,t]完全覆盖。

思路:

贪心。把区间按起点排序。若当前已经覆盖了区间[1,ri]。那么就找起点在该区间内终点最大的区间。开始写的线段树查最值。其实不用。线性扫描就行了。

详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const double PI=acos(-1.0);
const int maxn=100010;
typedef __int64 ll;
struct cow
{
    int st,ed;
} cw[25100];
bool cmp(cow a,cow b)
{
    return a.st<b.st;
}
int main()
{
    int t,n,i,ri,ma,ans;

    while(~scanf("%d%d",&n,&t))
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&cw[i].st,&cw[i].ed);
        sort(cw,cw+n,cmp);
        ri=ans=i=ma=0;
        while(i<n)
        {
            for(;i<n;i++)
                if(cw[i].st<=ri+1)
                    ma=max(ma,cw[i].ed);
                else
                    break;
            if(ma==ri)
                break;
            else
                ans++,ri=ma;
        }
        if(ri<t)
            ans=-1;
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值