POJ - 2376 Cleaning Shifts

Cleaning Shifts

POJ - 2376

AYIT-2021 609暑假集训第一周上 搜索和贪心

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during >which a cow can work. A cow starts work at the start time and finishes after the >end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:n头牛打扫T长的地方,下面给出每个牛的工作时间,求最少雇佣几只牛
题型:贪心,区间覆盖问题
注意:工作时间是闭区间,故1-6,7-10能打扫完1-10

#include <stdio.h>
#include <algorithm>
using namespace std;
struct dd
{
    int s,e;
}d[25010];
bool dq(dd x,dd y)
{
	if(x.s==y.s)return x.e<y.e;//注意 因为是找超过之后往回退一个,所以大的放后面
	return x.s<y.s;
}
int main()
{
    int i,n,t,rr,sum,mi,ll;
    scanf("%d%d",&n,&t);
    for(i=0;i<n;i++)
        for(i=0;i<n;i++)
			scanf("%d%d",&d[i].s,&d[i].e);
    sort(d,d+n,dq);
    rr=sum=mi=0;
    while(rr<t)
    {
        ll=rr+1;//左边界理论最大值 
        for(i=mi;i<n;i++)
            if(d[i].s<=ll&&d[i].e>=ll)
                rr=max(rr,d[i].e);//右边界实际值 
            else if(d[i].s>ll)
            {
                mi=i;//下一个区间的左边界位置
                break;
            }
        if(ll>rr)
           break;
        else
           sum++;
    }
    if(rr>=t)
    	printf("%d\n",sum);
    else
    	printf("-1\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值