POJ 2376 - Cleaning Shifts(贪心)

8 篇文章 0 订阅

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9242 Accepted: 2461

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

=============================

题意:一天分为T段,即1-T,有N头牛,从中选出一头或几头牛使至少每段都有一头牛工作,求所需牛数的最小值,不能做到输出-1


简单贪心。以开始时间为关键字进行排序,每次选择可以和上个结束时间相连接的、结束时间最晚的牛,若不能连接直接输出-1

给出几组数据:

3 10

2 4

3 6

7 10

输出-1

----------

3 10

1 4

4 7

7 9

输出-1

----------

3 10

1 10

2 3

4 5

输出1

---------

3 10

1 3

4 6

7 10

输出3


#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

struct cow
{
    int st;
    int ed;
}a[25555];

bool cmp(cow a,cow b)
{
    return a.st<b.st;
}

int main()
{
    int n,t,et=0,MAX=-1,p,ans=0;
    scanf("%d%d",&n,&t);
    for(int i=0;i<n;i++)
        scanf("%d%d",&a[i].st,&a[i].ed);
    sort(a,a+n,cmp);
    for(int i=0;i<n;i++)
    {
        if(a[i].st>et+1)
        {
            printf("-1\n");
            return 0;
        }
        while(a[i].st<=et+1&&i<n)
        {
            if(a[i].ed>MAX)
            {
                MAX=a[i].ed;
                p=i;
            }
            i++;
        }
        i--;
        et=a[p].ed;
        ans++;
        if(et>=t) break;
    }
    if(et<t) printf("-1\n");
    else printf("%d\n",ans);

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值