hdu 3006 The Number of set(思维+壮压DP)

The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1056    Accepted Submission(s): 655


Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
  
  
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
  
  
15 2
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   3007  3003  3004  3002  3005 
 

题意:

给你n个集合。集合中均为数字且数字的范围在[1,m]内。m<=14。现在问用这些集合能组成多少个集合自己本身也算。

思路:

开始有点无头绪。一看到m范围就乐了。正好用二进制压缩。第i为1表示集合里有i这个数。然后背包就行了。

详细见代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;

const int maxn=100010;
//typedef __int64 ll;
int dp[1<<15],s[110],base[15];
int main()
{
    int n,m,i,j,k,tp,ans;

    base[0]=1;
    for(i=1;i<=15;i++)
        base[i]=base[i-1]<<1;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof dp);
        dp[0]=1,ans=0;
        for(i=0;i<n;i++)
        {
            s[i]=0;
            scanf("%d",&k);
            for(j=0;j<k;j++)
            {
                scanf("%d",&tp);
                s[i]=s[i]|base[tp-1];
            }
        }
        for(i=0;i<n;i++)
            for(j=base[m]-1;j>=0;j--)
                if(dp[j])
                    dp[j|s[i]]=1;
        for(i=base[m]-1;i>=1;i--)
            if(dp[i])
                ans++;
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值