ZOJ1003 python AC

4 篇文章 0 订阅

又一题愉快的暴搜(深搜),不过对python使用递推还是有点不习惯,python的参数传递方式和C++差的有点多

好了,上题目

ZOJ1003:https://zoj.pintia.cn/problem-sets/91827364500/problems/91827364502

Crashing Balloon
Time Limit: 2000 msMemory Limit: 65536 KB

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she's crashed.  The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge his\her opponent's score.  The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input

343 49
3599 610
62 36

Sample Output

49
610
62

大致题意:

两名选手比赛踩气球,气球编号为1-100,得分为所踩气球的乘积,分数大的获胜。但由于分数可以谎报,所以需要验证,根据所报分数,优先满足分数小的选手所需要的气球,如果冲突,则判断分数小的获胜。每行输入两个分数,然后输出一个获胜者的分数。

分析:

题目意思即输入a,b,两个分数分解因数,在因数都在100以内的前提下,如果存在两套不重复的因数集合,满足乘积分别为a,b,则分数大的获胜,否则,分数小的获胜。但存在一种特殊情况:分数小的玩家谎报分数,那么无论分数大的是否说谎,都算大的赢(饿死胆小的)

由于只需要考虑100以下因数,且每个数字的气球只有三种情况:

1.被a踩了

2.被b踩了

3.没人踩

所以只需要简单的暴搜就好了,遍历每一种情况,当存在分数小的能被整除,但不存在a,b同时能被整除的情况时,分数小的获胜,否则都算分数大的获胜

代码如下:

# -*- coding: utf-8 -*-

import math

# bo1 = bo2 = False
def result(a, b, i):
    global bo1
    global bo2
    #两步判断:
    #1.只要a能被整除,bo1=ture
    #2.存在 a=b=1,即满足a,b都被整除,bo2=true
    if a == 1:
        bo1 = True
        if b == 1:
            bo2 = True
            return      #满足条件,都是真话,提前结束
    
    if i == 1:
        return

    #深搜   三条分支
    if a % i == 0:
        result(a // i, b, i - 1)  
    if b % i == 0:
        result(a, b // i, i - 1)
    result(a, b, i - 1)

if __name__ == "__main__":
    try:
        while 1:
            #输入获取
            x = input().split(' ')
            x1 = min(int(x[0]),int(x[1]))#x1为小, x2为大
            x2 = max(int(x[0]),int(x[1]))

            bo1 = bo2 = False
            if x1 == x2:
                num = x1
            else:
                result(x1, x2, 100)
                num = x1 if bo1 and not bo2 else x2
            print(num)

    except Exception:
        pass

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值