hdoj 1544 Palindromes

Palindromes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1062    Accepted Submission(s): 460


Problem Description
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

Now give you a string S, you should count how many palindromes in any consecutive substring of S.
 

Input
There are several test cases in the input. Each case contains a non-empty string which has no more than 5000 characters.

Proceed to the end of file.
 
output
A single line with the number of palindrome substrings for each case. 
 

Sample Input
  
  
aba aa
 

Sample Output
  
  
4 3
 
#include <iostream>
#include <vector>
#include <string>
using namespace std;
int main()
{
    string s;
    while(cin>>s)
    {
        int p,i,half,left,right,count;
        i=s.size();
        count=0;
        //从左到右钉住最后一个
        for(int p=0;p<i-1;p++)
        {
            half=((i-1)-p)/2;
            if(((i-1)-p)%2==0) //奇数
            {
                left=p+half-1;
                right=p+half+1;
            }
            else  //偶数
            {
                left=p+half;
                right=p+half+1;
            }
            while(p<=left)
            {
                if(s[left]==s[right])
                {
                    count++;
                    left--;
                    right++;
                }
                else break;
            }
        }
        for(int p=i-2;p>=1;p--)
        {
            half=p/2;
            if(p%2==0)
            {
                left=half-1;
                right=half+1;
            }
            else
            {
                left=half;
                right=half+1;
            }
            while(left>=0)
            {
                if(s[left]==s[right])
                {
                    count++;
                    left--;
                    right++;
                }
                else
                    break;
            }
        }
        cout<<count+i<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值