hud-1800-Flying to the Mars(贪心)

Flying to the Mars
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14181    Accepted Submission(s): 4525




Problem Description




In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……


After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 


 


Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);


 


Output
For each case, output the minimum number of broomsticks on a single line.
 


Sample Input
4
10
20
30
04
5
2
3
4
3
4
 


Sample Output
1

2

//hdu-1800-Flying to the Mars(贪心) 
//本题题意:此题要求等级高的可以教低士兵(他们可以共乘一条扫把),
//问最少需要多少条扫把 .
//解题思路:利用贪心思想,什么时候才能使扫把最少呢?
//由题知,等级高的可以带等级低的,那等级相同的就绝对不能乘一个扫把;
//所以,所需的最少扫把就是等级相同的士兵的总数。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[3100];
int main()
{
	int n,i,j,max,cnt;
	while(scanf("%d",&n)!=EOF)
	{
		max=1;
		for(i=0;i<n;i++)
		  scanf("%d",&a[i]);
		sort(a,a+n);
		for(i=1,cnt=1;i<n;i++)
		{
			if(a[i]!=a[i-1])
			  cnt=1;          //当相邻两个不相等时,说明有一个新值出现,让cnt=1,
			               //开始统计这个数出现的次数。 
			else
			  cnt++;//统计相同等级的个数 
	     if(cnt>max)
	       max=cnt;
	   }
	    printf("%d\n",max);	
	}
	 return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值