Keep on Truckin'

FJNU.1703

Description
Boudreaux and Thibodeaux are on the road again . . .
"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"
"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit
through all of them, so just keep that motor running!"
"We're not going to make it, I say!"
So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound
of his own wheels drive him crazy?

Input
Input to this problem will consist of a single data set. The data set will be formatted according to the
following description.
The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number
represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusiv

Output
There will be exactly one line of output. This line will be:
NO CRASH
if the height of the 18-wheeler is less than the height of each of the underpasses, or:
CRASH X
otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go
under (which means its height is less than or equal to the height of the 18-wheeler).
The height of the 18-wheeler is 168 inches.

Sample Input
180 160 170

Sample Output
CRASH 160

My Program

#include < iostream >
using   namespace  std;

int  main()
{
    
int a[3];
    
int i;
    
for(i=0;i<3;i++)
        cin
>>a[i];
    
for(i=0;i<3;i++)
        
if(a[i]<=168)
        
{
            cout
<<"CRASH "<<a[i]<<endl;
            i
=-1;
            
break;
        }

    
if(i==3)
        cout
<<"NO CRASH"<<endl;
    
return 0;
}

YOYO's Note: 
输入三个数判断哪个<=168 存在就输出那个数 否则就NO CRASH……

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值