Number Triangles

FJNU.1913

Description
Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 
          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5
In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

Input
The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.
There are multiple testcases, process to the end of file.

Output
A single line containing the largest sum using the traversal specified.

Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

My Program

#include < stdio.h >
#define  R 1005

int  main()
{
    
long r,i,j,s,t;
    
long m[2][R];
    
while(scanf("%d",&r)!=EOF)
    
{
        s
=0;
        
if(r>0)
        
{
            scanf(
"%d",&m[0][0]);
            
for(i=1;i<r;i++)
            
{
                s
=i%2;t=(i-1)%2;
                
for(j=0;j<=i;j++)
                    scanf(
"%d",&m[s][j]);
                m[s][
0]+=m[t][0];m[s][i]+=m[t][i-1];
                
for(j=1;j<i;j++)
                    m[s][j]
+=m[t][j-1]>m[t][j]?m[t][j-1]:m[t][j];
            }

            t
=(r-1)%2;
            s
=m[t][0];
            
for(i=1;i<r;i++)
                
if(m[t][i]>s)
                    s
=m[t][i];
        }

        printf(
"%ld ",s);
    }

    
return 0;
}

YOYO's Note:
┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄它是华丽的分隔线

【题意简述】

给定行数R和数字三角形每行每列的值,求最大可走的数字。


【粗略分析】

动态规划基本题。
但是1000的规模很容易超时。
经过分析不难发现,
每行的值都只于它的上一行有关,
因此采用了一个二维数组来存储。
滚动的方法是i%2。
最后找出最后一行的最大值即可。

【C源代码】

#include < stdio.h >
#define  R 1005

int  main()
{
    
long r,i,j,s,t;
    
long m[2][R];
    
while(scanf("%d",&r)!=EOF)
    
{
        s
=0;
        
if(r>0)
        
{
            scanf(
"%d",&m[0][0]);
            
for(i=1;i<r;i++)
            
{
                s
=i%2;t=(i-1)%2;
                
for(j=0;j<=i;j++)
                    scanf(
"%d",&m[s][j]);
                m[s][
0]+=m[t][0];m[s][i]+=m[t][i-1];
                
for(j=1;j<i;j++)
                    m[s][j]
+=m[t][j-1]>m[t][j]?m[t][j-1]:m[t][j];
            }

            t
=(r-1)%2;
            s
=m[t][0];
            
for(i=1;i<r;i++)
                
if(m[t][i]>s)
                    s
=m[t][i];
        }

        printf(
"%ld ",s);
    }

    
return 0;
}

【注意事项】

※ 用scanf/printf!!!不然会TLE..
※ 他们说,遇到i%2的时候,写成i&1会比较快。

【点评】

DP基本啊基本啊基本啊的题目。 
因为cin/cout费了很多次TLE……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值