Coconuts, Revisited

FJNU.1688

Description
The short story titled Coconuts, by Ben Ames Williams, appeared in the Saturday Evening Post on October 9, 1926. The story tells about five men and a monkey who were shipwrecked on an island. They spent the first night gathering coconuts. During the night, one man woke up and decided to take his share of the coconuts. He divided them into five piles. One coconut was left over so he gave it to the monkey, then hid his share and went back to sleep.
Soon a second man woke up and did the same thing. After dividing the coconuts into five piles, one coconut was left over which he gave to the monkey. He then hid his share and went back to bed. The third, fourth, and fifth man followed exactly the same procedure. The next morning, after they all woke up, they divided the remaining coconuts into five equal shares. This time no coconuts were left over.
An obvious question is ``how many coconuts did they originally gather?" There are an infinite number of answers, but the lowest of these is 3,121. But that's not our problem here.
Suppose we turn the problem around. If we know the number of coconuts that were gathered, what is the maximum number of persons (and one monkey) that could have been shipwrecked if the same procedure could occur?

Input
The input will consist of a sequence of integers, each representing the number of coconuts gathered by a group of persons (and a monkey) that were shipwrecked. The sequence will be followed by a negative number.

Output
For each number , determine the largest number of persons who could have participated in the procedure described aboveof coconuts. Display the results similar to the manner shown below, in the Sample Output. There may be no solution for some of the input cases; if so, state that observation.

Sample Input
25
30
3121
-1

Sample Output
25 coconuts, 3 people and 1 monkey
30 coconuts, no solution
3121 coconuts, 5 people and 1 monkey 

My Program

#include < iostream >
using   namespace  std;

int  Search( int  n)
{
    
int i,j,x;
    
for(i=10;i>1;i--)
    
{
        x
=n;j=i;
        
while(j)
        
{
            
if((x-1)%i!=0)break;
            x
-=(x-1)/i+1;j--;
        }

        
if(j==0&&x%i==0)
            
return i;
    }

    
return 0;
}


int  main()
{
    
int c,p;
    
while(cin>>c)
    
{
        
if(c==-1)
            
break;
        cout
<<c<<" coconuts, ";
        p
=Search(c);
        
if(p>0)
            cout
<<p<<" people and 1 monkey"<<endl;
        
else
            cout
<<"no solution"<<endl;
    }

    
return 0;
}

 

Source
North Central North America 1997

YOYO's Note:
┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄┄它是华丽的分隔线

【题意简述】

有n个椰子(话说我一直以为应该是核桃……),p个人和一只猴子,
假设有某晚上 第一个人起来后把这些椰子分成p份,恰好多余一个给了猴子,自己藏了一份;
第二个人起来后又把剩下的椰子分成p份,恰好又多余一个给猴子,自己藏了一份……
这样p个人都分完后正好没有剩余,现已知n数,求满足条件的最大的p。


【粗略分析】

一直没注意是求最大的……
于是从2开始inc循环一直WA……
后来终于看到了determine the largest number of persons who could have participated in the procedure described aboveof coconuts这句话。。便从10起downto勒。。

【C++源代码】

#include < iostream >
using   namespace  std;

int  Search( int  n)
{
    
int i,j,x;
    
for(i=10;i>1;i--)
    
{
        x
=n;j=i;
        
while(j)
        
{
            
if((x-1)%i!=0)break;
            x
-=(x-1)/i+1;j--;
        }

        
if(j==0&&x%i==0)
            
return i;
    }

    
return 0;
}


int  main()
{
    
int c,p;
    
while(cin>>c)
    
{
        
if(c==-1)
            
break;
        cout
<<c<<" coconuts, ";
        p
=Search(c);
        
if(p>0)
            cout
<<p<<" people and 1 monkey"<<endl;
        
else
            cout
<<"no solution"<<endl;
    }

    
return 0;
}

【注意事项】

※ 每个人后面要输出and 1 monkey
※有可能no solution
※ 没有1个人的情况,所以down到2就可以勒

【点评】

增扫兴那天不在~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
解决这个问题King Julien rules the Madagascar island whose primary crop is coconuts. If the price of coconuts is P , then King Julien’s subjects will demand D(P ) = 1200 − 100P coconuts per week for their own use. The number of coconuts that will be supplied per week by the island’s coconut growers is S(p) = 100P. (a) (2 pts) Calculate the equilibrium price and quantity for coconuts. (b) (2 pts) One day, King Julien decided to tax his subjects in order to collect coconuts for the Royal Larder. The king required that every subject who consumed a coconut would have to pay a coconut to the king as a tax. Thus, if a subject wanted 5 coconuts for himself, he would have to purchase 10 coconuts and give 5 to the king. When the price that is received by the sellers is pS, how much does it cost one of the king’s subjects to get an extra coconut for himself? (c) (3 pts) When the price paid to suppliers is pS, how many coconuts will the king’s subjects demand for their own consumption (as a function of pS)? 2 (d) (2 pts) Under the above coconut tax policy, determine the total number of coconuts demanded per week by King Julien and his subjects as a function of pS. (e) (3 pts) Calculate the equilibrium value of pS, the equilibrium total number of coconuts produced, and the equilibrium total number of coconuts consumed by Julien’s subjects. (f) (5 pts) King Julien’s subjects resented paying the extra coconuts to the king, and whispers of revolution spread through the palace. Worried by the hostile atmosphere, the king changed the coconut tax. Now, the shopkeepers who sold the coconuts would be responsible for paying the tax. For every coconut sold to a consumer, the shopkeeper would have to pay one coconut to the king. For this new policy, calculate the number of coconuts being sold to the consumers, the value per coconuts that the shopkeepers got after paying their tax to the king, and the price payed by the consumers.
最新发布
03-07

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值