数据结构实验之二叉树四:还原二叉树

数据结构实验之二叉树四:还原二叉树

Time Limit: 1000MS Memory Limit: 65536
KB
Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input
输入数据有多组,每组数据第一行输入 1 个正整数 N(1 <= N <= 50) 为树中结点总数,随后 2 行先后给出先序和中序遍历序列,均是长度为 N 的不包含重复英文字母 ( 区分大小写 ) 的字符串。

Output
输出一个整数,即该二叉树的高度。
Example Input
9 
ABDFGHIEC
FDHGIBEAC
Example Output
5

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
using namespace std;
struct node
{
    char data;
    struct node *l,*r;
};
struct node *creat(int n,char a[],char b[])
{
    struct node *root;
    int t;
    char *p;
    if(n==0)
     return NULL;//若写为root=NULL;为错误;可在下面加一个else语句;
        root=(struct node *)malloc(sizeof(struct node));
        root->data=a[0];
    for(p=b; p!='\0'; p++)
    {
        if(*p==a[0])
            break;
    }
    t=p-b;
    root->l=creat(t,a+1,b);
    root->r=creat(n-t-1,a+1+t,p+1);
    return root;
};
int deepth(struct node *root)
{
    int d=0;//注意赋初值
    if(root)
    {
        int dl=deepth(root->l);
        int dr=deepth(root->r);
        d=dl>dr?dl+1:dr+1;
    }
    return d;
}
int main()
{

    int m,n;
    char a[101],b[101];
    while(cin>>n)
    {
        struct node *root;
        cin>>a>>b;
        root=creat(n,a,b);
        m=deepth(root);
        cout<<m<<endl;
    }
    return 0;
}<pre name="code" class="cpp">#include <iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
struct node
{
    int data;
    struct node *l,*r;
};
struct node *creat(int n,char a[],char b[])
{
    struct node *root;
    int t;
    char *p;
    if(n==0)
       root=NULL;
    else
    {
    root=new node;
    root->data=a[0];
    for(p=b;p!='\0';p++)
    {
        if(*p==a[0])
            break;
    }
    t=p-b;
    root->l=creat(t,a+1,b);
    root->r=creat(n-t-1,a+t+1,p+1);
    }
    return root;
};
int deep(struct node *root)
{
    int d=0;
    if(root)
    {
        int dl=deep(root->l);
        int dr=deep(root->r);
        d=dl>dr?dl+1:dr+1;
    }
    return d;
}
int main()
{
     int n,m;
     char a[101],b[101];
     struct node *root;
     while(cin>>n)
     {
         cin>>a>>b;
         root=creat(n,a,b);
         m=deep(root);
         cout<<m<<endl;
     }
    return 0;
}

 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值