正方形

正方形

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
给出四个点,判断这四个点能否构成一个正方形。
Input
 输入的第一行包含一个整数T(T≤30)表示数据组数,每组数据只有一行,包括8个整数x1, y1, x2, y2,x3,y3,x4,y4(数据均在-1000,1000 之间)以逆时针顺序给出四个点的坐标。

Output
 每组数据输出一行,如果是正方形,则输出: YES, 否则,输出:NO。
Example Input
20 0 1 0 1 1 0 1-1 0 0 -2 1 0 2 0
Example Output
YESNO
Hint
 

Author

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		for (int i = 0; i < n; i++) {
			Point p1 = new Point(sc.nextInt(), sc.nextInt());
			Point p2 = new Point(sc.nextInt(), sc.nextInt());
			Point p3 = new Point(sc.nextInt(), sc.nextInt());
			Point p4 = new Point(sc.nextInt(), sc.nextInt());
			if (p1.distance(p2) == p2.distance(p3) && p2.distance(p3) == p3.distance(p4)
					&& p3.distance(p4) == p4.distance(p1) && p1.distance(p2) + p2.distance(p3) == p1.distance(p3)) {
				System.out.println("YES");
			} else {
				System.out.println("NO");
			}
		}
		sc.close();
	}
}

class Point {
	int x;
	int y;

	public Point(int x, int y) {
		this.x = x;
		this.y = y;
	}

	public int distance(Point p) {
		return (x - p.x) * (x - p.x) + (y - p.y) * (y - p.y);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值