hdu 1024Max Sum Plus Plus 最大M段字段和 单调优化DP 从一类单调性问题看算法的优化

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11231    Accepted Submission(s): 3691


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j xor i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
#include<stdio.h>
#include<string.h>
#define size 1000100
#define INF 1<<30
int dp[2][size];
int num[size];
int k,n;
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int i,j,l,ans;
	while(scanf("%d %d",&k,&n))
	{
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&num[i]);
			dp[1][i]=dp[0][i]=0;
		}
		for(i=1;i<=k;i++)
		{
			ans=-INF;
			for(j=i;j<=n;j++)//前j-1个取i段;前j-1个取i-1段(上一状态)
			{                //接着放  ,自己另起一段,此时dp[0][j-1]中存的还是前j-1个数组成i-1的最大值
				dp[1][j]=max(dp[1][j-1],dp[0][j-1])+num[j];//dp[1]就是已经把这个数放了
				dp[0][j-1]=ans;//用过再更新,变成前j-1个数存i段的最大和,不影响下一层,到下一层就是j-2了
				if(ans<dp[1][j])//若这个数不该放,前面dp[1][j]加上了num[j],也不改变ans的值
				{
					ans=dp[1][j];  //ans存的是i段的最优结果,把每次的最大和存在dp[0]中 
				}                  
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值