Docker-Compose安装及使用

Docker入门及技术指南

参见:https://blog.csdn.net/yan_dk/article/details/89427641

安装Docker-Compose

  • 通过pip安装(pip是python的包管理工具)

# pip -V

若不存在,就执行如下

#yum -y install epel-release

#yum install python-pip

升级pip

#pip install --upgrade pip

直至出现如下

pip安装成功,继续安装。

系统自动版本安装docker-compose  

#pip install docker-compose  

也可指定版本安装

#pip install docker-compose==1.22

查看版本

#docker-compose --version

出现上述报错

原因:python库中urllib3 (1.22) or chardet (2.2.1) 的版本不兼容

解决如下:

 pip uninstall urllib3
 pip uninstall chardet
 pip install requests

Curl方式下载新的版本

curl -L https://github.com/docker/compose/releases/download/1.22.0/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose

修改权限

chmod +x /usr/local/bin/docker-compose

查看版本

#docker-compose -v

docker-compose安装成功。

docker-compose使用实例

参见:Docker构建Redis  

https://blog.csdn.net/yan_dk/article/details/89740396

相关推荐
©️2020 CSDN 皮肤主题: 技术工厂 设计师:CSDN官方博客 返回首页