关于pyqt5调试中的问题

运行版本为:python3.7+pycharm2019+pyqt5
在这里插入图片描述
关于.ui文件同步成同名的.py文件,报上述Error:one input ui-file must be specified错误,提供一条命令行解决方案:可以先将cmd工作目录cd到.ui文件下,然后输入命令行:pyuic5 -o main.py main.ui
-o是操作参数,表示要生成一个文件
main.py表示要生成的文件
main.ui是在此之前用QTCreator生成的包含UI设计的.ui文件

发布了55 篇原创文章 · 获赞 3 · 访问量 2361
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 深蓝海洋 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览