[NWPU][2014][TRN][17]最小生成树 B - 基础 POJ 2421

描述:

有n个村庄,编号为1 ,2 ,3 ,,,n  应该建造道路使他们互相可达

对输入数据

3
0 990 692
990 0 179
692 179 0
1
1 2
意思有3个村庄,
0 990 692
990 0 179
692 179 0
意思是1号到1,2,3的距离分别为0 990 692
1
1 2
意思是有一条道路已经接通,就是1号与2号间的道路

解法:

kruskal算法,建造最小生成树即可


B - 基础
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

#include<iostream>
using namespace std;
#define inf  0xffffff
const int MAXN = 105;
int maze[MAXN][MAXN], vis[MAXN], mincost[MAXN];
int n, q;

int prim(int v)
{
    for(int i = 1; i <= n; i++)
        mincost[i] = maze[v][i];
    vis[v] = 1;
    int sum =0, k;
    for(int i = 2; i <= n; i++)
    {
        int mina = inf;
        for(int j = 1; j <= n; j++)
        {
            if(mincost[j] <= mina && !vis[j])
            {
                mina = mincost[j]; k = j;
            }
        }
        sum += mina;vis[k] = 1;
        for(int j = 1; j <= n; j++)
        {
            if(mincost[j] >= maze[k][j] && !vis[j])            {
                mincost[j] = maze[k][j];
            }
        }
    }
    return sum;
}

int main()
{
    cin >> n;
    for(int i = 1; i <= n; i++)
    {
        for(int j = 1; j <= n; j++)
            cin >> maze[i][j];
    }
    cin >> q;
    for(int i = 1; i <= q; i++)
    {
        int a, b;
        cin >> a >> b;
        maze[a][b] = maze[b][a] =0 ;
    }
    cout << prim(1) << endl;
    return 0;
}
//kruskal方法再写一遍
#include <iostream>
#include<algorithm>
using namespace std;
const int N = 105;
int father[N], rank[N];
struct edge
{
    int u, v, value;
}ee[N * N];
int graph[N][N], flag[N][N], numedge, n;

bool cmp(edge a, edge b)//按照edge.value的顺序从小到大排序
{
    return a.value < b.value;
}

void init(int n)
{
    for(int i = 1; i <= n; i++)
    {
        father[i] = i;
        rank[i] = 0;
    }
}

int find(int x)
{
    if(x != father[x])
        father[x] = find(father[x]);
    return father[x];
}

bool same(int x, int y)
{
    return find(x) == find(y);
}

void unite(int x, int y)
{
    x = find(x);
    y = find(y);
    if(x == y) return ;
    if(rank[x] < rank[y])
        father[x] = y;
    else
    {
        father[y] = x;
        if(rank[x] == rank[y])
            rank[x]++;
    }
}

int kruskal()
{
    sort(ee, ee + numedge, cmp);
    init(n);
    int sum = 0;
    for(int i = 0; i < numedge; i++)
    {
        edge e = ee[i];
        if(!same(e.u, e.v))
        {
            unite(e.u, e.v);
            sum += e.value;
        }
    }
    return sum;
}

int main()
{
    //freopen("input.txt", "r", stdin);
    cin >> n;
    for(int i = 1; i <= n; i++)
        for(int j = 1;j <= n; j++)
            cin >> graph[i][j];
    int q, a, b;
    cin >> q;
    for(int i = 1; i <= q; i++)
    {
        cin >> a >> b;
        flag[a][b] = 1;
    }
    numedge = 0;
    for(int i = 1; i < n; i++)
    {
        for(int j =1; j <= n; j++)
        {
            if(flag[i][j])
            {
                ee[numedge].u = i;
                ee[numedge].v = j;
                ee[numedge].value = 0;
                numedge++;
            }
            else
            {
                ee[numedge].u = i;
                ee[numedge].v = j;
                ee[numedge].value = graph[i][j];
                numedge++;
            }
        }
    }
    int ans = kruskal();
    cout << ans << endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值