bfs广搜:打印路径

16 篇文章 0 订阅
14 篇文章 0 订阅

题意:

B - 迷宫问题
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

定义一个二维数组:
int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


代码:

//@auther yangZongJun
/********************************************//**
Date  : 2015
题目来源:
题    意:
解题思路:
 ***********************************************/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <string>
#include <cstring>
#include <queue>

using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
const int MAXN = 5;
const int INF = 100000000;

typedef pair<int, int> P;
int n, m, sx, sy, gx, gy;//迷宫大小,起点、终点的坐标
char maze[MAXN][MAXN];
int d[MAXN][MAXN];//到各个位置的最短距离的数组
int pre[105];//记录节点的前驱,用于输出搜走的路径
int dx[4] = {0, 1, 0, -1};
int dy[4] = {1, 0, -1, 0};

//递归地打印路径
void print(int gx, int gy)
{
    if(pre[gx*n+gy] != -1)
    {
        print(pre[gx*n+gy]/5, pre[gx*n+gy]%5);
    }
    printf("(%d, %d)\n", gx, gy);
}

void bfs()
{
    for(int i = 0; i < n; i++)
        for(int j = 0; j < m; j++)
            d[i][j] = INF;
    memset(pre, 0, sizeof(pre));
    pre[0] = -1;
    //pre[gx*n+gy] = 1;//只需pre[gx*n+gy] != -1就行了,因此可以不要

    queue<P> que;
    que.push(P(sx, sy));
    d[sx][sy] = 0;

    while(que.size())
    {
        P p = que.front();
        que.pop();
        if(p.first == gx && p.second == gy)
        {
            print(gx, gy);return ;
            //break;
        }
        for(int i = 0; i < 4; i++)
        {
            int nx = p.first + dx[i], ny = p.second + dy[i];
            if(0<=nx&&nx<n&&0<=ny&&ny<m&&maze[nx][ny]!='1'&&d[nx][ny]== INF)
            {
                que.push(P(nx, ny));
                d[nx][ny] = d[p.first][p.second] + 1;
                pre[nx*n+ny] = p.first*n + p.second;
            }
        }
    }
    //printf("%d\n", d[gx][gy]);//打印最短距离,若答案==INF,则无法到达
}

int main()
{
    freopen("input.txt", "r", stdin);
    n = m = 5;
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < m; j++)
        {
            scanf("%s", &maze[i][j]);
            //scanf(" %c", &maze[i][j]);
            //读入char类型的数据,"%s" 等价于" %c",都是忽略空格
        }
    }
    sx = sy = 0;
    gx = gy = 4;
    bfs();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值