单调队列

题目;

Bad Hair Day
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14491 Accepted: 4783

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c 1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

Source


暴力是肯定过不了的

//@auther yangZongJun
/********************************************//**
Date  : 2014/03/08
题目来源:poj3250
题    意:
解题思路:
 ***********************************************/
#include <iostream>
#include <cstdio>

using namespace std;
const int MAXN = 80000+5;
int a[MAXN], n;

int main()
{
    //freopen("input.txt", "r", stdin);
    while(~scanf("%d", &n))
    {
        int ans = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
        }
        for(int i = 0; i < n; i++)
        {
            int start = a[i];
            for(int j = i+1; j < n; j++)
            {
                if(a[j] < start)
                {
                    ans++;
                }
                else break;
            }
        }
        printf("%d\n", ans);
    }
    return 0;

}

单调栈

#include <iostream>
#include <cstdio>
#include <stack>

using namespace std;

const int MAXN = 80000+5;
stack<int> s;
int n, temp;

int main()
{
    //freopen("input.txt", "r", stdin);
    while(~scanf("%d", &n))
    {
        long long ans  = 0;
        //scanf("%d", &temp);
        //s.push(temp);
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &temp);
            while(!s.empty() && s.top() <= temp)
            {
                s.pop();
            }
            ans += s.size();
            s.push(temp);
        }
        printf("%lld\n", ans);
        while(!s.empty())
            s.pop();
        }
    return 0;
}

单调队列

#include <iostream>
#include <cstdio>
#include <deque>

using namespace std;

const int MAXN = 80000+5;
deque<int> dq;
int n, temp;

int main()
{
    freopen("input.txt", "r", stdin);
    while(~scanf("%d", &n))
    {
        long long ans  = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &temp);
            while(!dq.empty() && dq.back() <= temp)
            {
                dq.pop_back();
            }
            ans += dq.size();
            dq.push_back(temp);
        }
        printf("%lld\n", ans);
        while(!dq.empty()) dq.pop_back();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值