HDU 1003

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

 

#include <iostream>
using namespace std;
int main()
{
	int caseCount,n,temp,start,end,max,thisSum,x;
	cin>>caseCount;
	for (int i=1;i<=caseCount;i++)
	{
		cin>>n>>temp;
		thisSum=max=temp;
		start=end=x=1;
		for (int j=2;j<=n;j++)
		{   
			cin>>temp;
			if (thisSum+temp<temp)
				thisSum=temp,x=j;
			else
				thisSum+=temp;
			if (thisSum>max)
				max=thisSum,start=x,end=j;
		}
		cout<<"Case "<<i<<":"<<endl<<max<<" "<<start<<" "<<end<<endl;
		if (i!=caseCount)
			cout<<endl;
	}
	return 0;
}


代码比较简单,就不解释了。OO 

DP经典问题,求最大连续字段和。此题的解法与王晓东的《计算机算法设计与分析》上的解法有一点不同。首先,王晓东教授假设当所有整数为负整数时定义其最大字段和为0,但是这题要求当所有数为负数时其最大字段和不为0(可为负)。于是,要在原来的算法基础上做一些改变。最基本的最大字段和问题的动态规划算法为:

int MaxSum(int n,int *a)
{
  int sum = 0,b=0;
  for(int i = 1;i <=n;i++){
      if(b>0) b+=a[i];
      else b = a[i];
   if(b > sum ) sum = b;
}
   return sum;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值