HDU 2054 A==B?

Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input
each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input
1 2
2 2
3 3
4 3

Sample Output
NO
YES
YES

NO

这题看似简单其实没那么简单,第一数组得开很大,关键是小数点的处理。

1.00与1相等    1.与1相等

处理好小数点剩下的就是字符串比较函数就可以解决。

strstr函数用法:

strstr(str1,str2) 函数用于判断字符串str2是否是str1的子串。如果是,则该函数返回str2在str1中首次出现的地址;否则,返回NULL。
strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。
该函数返回字符串的其余部分(从匹配点)。如果未找到所搜索的字符串,则返回 false。


举例
#include<cstdio>
#include <string.h>
main()
{
    char *s="GoldenGlobalView";
    char *l="lob";
    char *p;
    p=strstr(s,l);
    if(p)
        printf("%s",p);
    else
        printf("NotFound!");
    getchar();
    return 0;
}


#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char a[100000],b[100000];
void change(char s[])
{
    int i,len;
    len  = strlen(s);
    if(strstr(s,"."))
    {
        for(i = len-1; s[i] == '0'; i--)
        {
            s[i] = '\0';
            len--;
        }
    }
    if(s[len-1] == '.')
        s[len-1] = '\0';
}

int main()
{

    while(cin>>a>>b)
    {
        change(a);
        change(b);
        if(strcmp(a,b))
       cout<<"NO"<<endl;
        else
        cout<<"YES"<<endl;
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值