HDU 2054

A == B ?


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 


Input
each test case contains two numbers A and B.
 


Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 


Sample Input
1 2
2 2
3 3
4 3
 


Sample Output
NO
YES
YES
NO
#include <stdio.h>  
#include <string.h>  
#include <iostream>  
using namespace std;
char a[100000], b[100000];
void change(char s[])
{
	int i, len;
	len = strlen(s);//判断字符串的长度
	if (strstr(s, "."))//strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。
	{
		for (i = len - 1; s[i] == '0'; i--)//将字符串后的0消除
		{
			s[i] = '\0';
			len--;
		}
	}
	if (s[len - 1] == '.')//将字符换后的点消除s
		s[len - 1] = '\0';
}

int main()
{

	while (scanf("%s%s", a, b) != EOF)
	{
		change(a);
		change(b);
		if (strcmp(a, b))
			printf("NO\n");
		else
			printf("YES\n");
	}

	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值