HDU 1671 Phone List(字典树)

Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO

YES

题目意思:存在一个字符串包含另一个字符串的输出NO,反之YES

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

typedef struct Trie
{
    int v;
    Trie *next[10];
} Trie;

Trie *root;

void createTrie(char *str)
{
    int len = strlen(str);
    Trie *p = root, *q;
    for(int i=0; i<len; ++i)
    {
        int id = str[i]-'0';
        if(p->next[id] == NULL)
        {
            q = (Trie *)malloc(sizeof(Trie));///创建一个节点
            q->v = 1;
            for(int j=0; j<10; ++j)///初始化
                q->next[j] = NULL;
            p->next[id] = q;///将新节点的地址保存在指针数组中
            p = p->next[id];///头指针移动
        }
        else
        {
            p->next[id]->v++;
            p = p->next[id];
        }
    }
    p->v = -1;

}

int findTrie(char *str)
{
    int len = strlen(str);
    Trie *p = root;
    for(int i=0; i<len; ++i)
    {
        int id = str[i]-'0';
        p = p->next[id];
        if(p == NULL)
            return 0;
        if(p->v == -1)
            return -1;
    }
    return -1;
}

int deal(Trie* T)
{
    //这是把T清空,一开始没加这个,结果MLE.
    int i;
    if(T==NULL)
        return 0;
    for(i=0; i<10; i++)
    {
        if(T->next[i]!=NULL)
            deal(T->next[i]);
    }
    free(T);
    return 0;
}

int main()
{
    //freopen("input.txt", "r", stdin);
    char str[15];
    int nCases, nNum;
    bool flag;
    scanf("%d", &nCases);
    while(nCases--)
    {
        flag = 0;
        root = (Trie *) malloc (sizeof(Trie));
        for(int i=0; i<10; ++i)
            root->next[i] = NULL;
        scanf("%d", &nNum);
        for(int i=0; i<nNum; ++i)
        {
            scanf("%s", str);
            if(findTrie(str) == -1)
                flag = 1;
            if(flag)   ///优化
                continue;
            createTrie(str);
        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
        deal(root);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值