HDU1671:Phone List(字典树)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19457    Accepted Submission(s): 6568


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
 
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
 
  
NO YES
 

Source
题意:给出N个电话号码,若果其中一个号码为另一个号码的前缀,就输出NO,否则输出YES。

思路:如果a是b的前缀,当a比b先进入字典树时,处理b容易发现a已经存在。当b比a先进入字典树时,处理a时加个mark变量记录a有无产生新节点,无就证明以a为前缀的号码已经存在。另一种方法是用string存号码,按长度小到大排序,就能肯定短的先进入字典树了,不过这样做效率较低。

# include <iostream>
# include <cstdio>
# include <algorithm>
# include <cstring>
using namespace std;

int cnt, flag;
char s[10005][13];
struct node
{
    int next[10], tag;
}tri[100050];

void add(char *s)
{
    int pos = 0, mark = 0, len = strlen(s);
    for(int i=0; i<len; ++i)
    {
        int t = s[i]-'0';
        if(!tri[pos].next[t])
        {
            mark = 1;
            tri[pos].next[t] = ++cnt;
        }
        pos = tri[pos].next[t];
        if(tri[pos].tag)
        {
            flag = 1;
            break;
        }
    }
    tri[pos].tag = 1;
    if(!mark)
        flag = 1;
}

int main()
{
    int t, n;
    scanf("%d",&t);
    while(t--)
    {
        flag = cnt = 0;
        scanf("%d",&n);
        memset(tri, 0, sizeof(tri));
        for(int i=0; i<n; ++i)
            scanf("%s",s[i]);
        for(int i=0; i<n; ++i)
            if(!flag)
                add(s[i]);
        if(flag)
            puts("NO");
        else
            puts("YES");
    }
}


转载于:https://www.cnblogs.com/junior19/p/6729886.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值