HDU 2660 Accepted Necklace(DFS解01背包)

Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.

Output
For each case, output the highest possible value of the necklace.

Sample Input
1
2 1
1 1
1 1
3

Sample Output

1

题意:给出宝石的数目n,制成项链所需的宝石个数k,然后再给出每个宝石的价值与重量,还有母亲能接受项链的最大重量,求在最大重量范围内,项链的价值尽可能大。

DFS解法:

#include<iostream>
#include<cstring>
using namespace std;
int maxn,n,k,weight;
int vis[21];
struct node
{
    int v,w;
} a[21];
void dfs(int v,int w,int n1,int k1)
{
    if(w==weight||k1==k)
    {
        if(maxn<v)
            maxn=v;
        return;
    }
    for(int i=n1; i<n; i++)
    {
        if(!vis[i]&&w+a[i].w<=weight)
        {
           vis[i]=1;
           dfs(v+a[i].v,w+a[i].w,i+1,k1+1);
           vis[i]=0;
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        for(int i=0; i<n; i++)
            cin>>a[i].v>>a[i].w;
        cin>>weight;
        memset(vis,0,sizeof(vis));
        maxn=-1;
        dfs(0,0,0,0);
        cout<<maxn<<endl;
    }
}
背包解法:

#include<iostream>
#include<cstring>
using namespace std;
int dp[1022][22];
struct node
{
    int v,w;
} a[21];
int main()
{
    int t,i,j,z,n,k,w;
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        for(i=1;i<=n;i++)
            cin>>a[i].v>>a[i].w;
            cin>>w;
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
            for(j=w;j>=a[i].w;j--)
                for(z=1;z<=k;z++)
            dp[j][z]=max(dp[j][z],dp[j-a[i].w][z-1]+a[i].v);
        cout<<dp[w][k]<<endl;
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值