1079. Total Sales of Supply Chain (25)

题目:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4
注意:
1、我刚开始是用回溯来计算每一个retailer的销售价格,导致最后一个case超时,原因当然是效率太低,重复计算的太多了。
2、后来用BFS来一层一层计算每一层member的销售价格,然后直接计算得出总销售额,这样可以ac。
3、可见算法的设计对效率的影响多么重要!!!

代码:
//1079
#include<iostream>
#include<vector>
using namespace std;

int main()
{
	int n;
	double price,rate;
	scanf("%d%lf%lf",&n,&price,&rate);
	rate=rate/100+1;
	vector<vector<int>>chain;//the chain net
	chain.resize(n);
	vector<double>Prc;//priceRate[i] is the rate of original price of member i
	Prc.assign(n,price);
	//retailer:the index of retailer
	//product:the amount of products of each retailers
	vector<int>retailer,product;
	for(int i=0;i<n;++i)
	{
		int m;
		scanf("%d",&m);
		if(m==0)
		{//if m=0,record the index of this retailer and his sale amount
			int p;
			scanf("%d",&p);
			retailer.push_back(i);
			product.push_back(p);
		}
		else
		{//or record the chain
			chain[i].resize(m);
			for(int j=0;j<m;++j)
				scanf("%d",&chain[i][j]);
		}
	}
	vector<int>cur;//the current level of distributor
	cur=chain[0];
	while(!cur.empty())
	{//calculate the price of each istributor and retailer
		vector<int>next;//the next level of distributor
		for(int i=0;i<cur.size();++i)
		{
			Prc[cur[i]]=price*rate;
			for(int j=0;j<chain[cur[i]].size();++j)
				next.push_back(chain[cur[i]][j]);
		}
		cur=next;
		price *= rate;//refresh the price of this level
	}
	double total=0;
	for(int i=0;i<retailer.size();++i)
	{//calculate sales of each retailer and sum them up
		total += product[i]*Prc[retailer[i]];
	}
	printf("%.1f\n",total);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值