1080. Graduate Admission (30)

题目:

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4
注意:
1、按照题意排序,然后模拟录取过程,从排名靠前的往排名靠后的一次录取,在处理当前学生的时候,从第一志愿到末尾的志愿一次判断,遇到该志愿的学校未录满或者排名与该志愿学校录取的最后一个学生的排名一样则可被该学校录取,然后不再考虑其他志愿。
2、不知道测试点中有没有某个学校的quota=0的情况,但我下面的代码还是把这种情况考虑进去了,一次ac。

代码:
//1080
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

struct student
{
	int id;//student's id
	int Ge,Gi;//grade
	int total;//total grade
	int choise[5];
	bool operator > (const student &s)const
	{
		if(Ge+Gi!=s.Ge+s.Gi)
			return Ge+Gi>s.Ge+s.Gi;
		else
			return Ge>s.Ge;
	}
};
int main()
{
	int n,m,k;//
	scanf("%d%d%d",&n,&m,&k);
	vector<int>quota;
	quota.resize(m);
	for(int i=0;i<m;++i)
		scanf("%d","a[i]);
	vector<student>app;//all application records
	app.resize(n);
	for(int i=0;i<n;++i)
	{
		scanf("%d%d",&app[i].Ge,&app[i].Gi);
		app[i].total=app[i].Ge+app[i].Gi;
		app[i].id=i;//record the id of this student!!!
		for(int j=0;j<k;++j)
			scanf("%d",&app[i].choise[j]);
	}
	sort(app.begin(),app.end(),greater<student>());
	vector<vector<int>>admission;//the admission result of each school
	admission.resize(m);	
	for(int i=0;i<n;++i)
	{
		for(int j=0;j<k;++j)
		{
			if(quota[app[i].choise[j]]>0)
			{
				int cursch=app[i].choise[j];//the index of current school
				if(admission[cursch].size()<quota[cursch] || 
					(app[i].total==app[admission[cursch][admission[cursch].size()-1]].total
						&&app[i].Ge==app[admission[cursch][admission[cursch].size()-1]].Ge))
				{//if preferred shcool is not exceeded or
				 //this student rank the same with the last admited student
					admission[cursch].push_back(i);//add the index of this student
					break;
				}
			}
		}
	}
	for(int i=0;i<m;++i)
	{
		if(admission[i].size()==0)
			printf("\n");
		else
		{
			vector<int>id;
			for(int j=0;j<admission[i].size();++j)
				id.push_back(app[admission[i][j]].id);//convert the index to student id
			sort(id.begin(),id.end());
			printf("%d",id[0]);
			for(int j=1;j<id.size();++j)
				printf(" %d",id[j]);
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
select * from ( SELECT P.PATIENT_ID, P.VISIT_ID, PM.NAME, PM.SEX, P.ADMISSION_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_ADMISSION_TO ) AS DEPT_ADM, P.DISCHARGE_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_DISCHARGE_FROM ) AS DEPT_DIS, DATEDIFF( DAY, P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) AS INPAT_DAYS, P.DOCTOR_IN_CHARGE --datediff(day, P.ADMISSION_DATE_TIME,P.DISCHARGE_DATE_TIME) as zyts FROM PAT_VISIT P INNER JOIN PAT_MASTER_INDEX PM ON PM.PATIENT_ID = P.PATIENT_ID WHERE select * from ( SELECT P.PATIENT_ID, P.VISIT_ID, PM.NAME, PM.SEX, P.ADMISSION_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_ADMISSION_TO ) AS DEPT_ADM, P.DISCHARGE_DATE_TIME, ( SELECT TOP 1 DP.DEPT_NAME FROM DEPT_DICT DP WHERE DP.DEPT_CODE = P.DEPT_DISCHARGE_FROM ) AS DEPT_DIS, DATEDIFF( DAY, P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) AS INPAT_DAYS, P.DOCTOR_IN_CHARGE --datediff(day, P.ADMISSION_DATE_TIME,P.DISCHARGE_DATE_TIME) as zyts FROM PAT_VISIT P INNER JOIN PAT_MASTER_INDEX PM ON PM.PATIENT_ID = P.PATIENT_ID WHERE P.DISCHARGE_DATE_TIME >= '2016-01-01' AND P.DISCHARGE_DATE_TIME < = '2023-07-10' AND DATEDIFF( DAY,P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) >= 30 ) t order by inpat_days desc P.DISCHARGE_DATE_TIME >= '2016-01-01' AND P.DISCHARGE_DATE_TIME < = '2023-07-10' AND DATEDIFF( DAY,P.ADMISSION_DATE_TIME, P.DISCHARGE_DATE_TIME ) >= 30 ) t order by inpat_days desc 帮我把这段sql优化一下
最新发布
07-25

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值