1084. Broken Keyboard (20)

题目:

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI
注意:
1、先把输入的两个字符串里面的小写字母全部转换成大写字母,然后再逐一进行比较判断该key是否broken。
2、可以使用一个数组来储存每个broken key是否已经输出。

代码:
//1084
#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	char origin[85],out[85];
	scanf("%s%s",origin,out);
	for(int i=0;i<strlen(out);++i)
		if(out[i]>='a' && out[i]<='z')
			out[i]=out[i]-'a'+'A';//convert all lower to upper
	int index=0;//index of out
	int exist[256]={0};//flag of existance of broken keys
	for(int i=0;i<strlen(origin);++i)
	{
		if(origin[i]>='a' && origin[i]<='z')
			origin[i]=origin[i]-'a'+'A';//convert all lower to upper
		if(origin[i]!=out[index] && !exist[origin[i]])
		{//this key is broken and has not been printed
			printf("%c",origin[i]);
			exist[origin[i]]=1;
		}
		else if(origin[i]==out[index])
			++index;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值