1085. Perfect Sequence (25)

题目:

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
注意:
1、这里先排序再使用二分法搜索来找到<=m*p的那个最大的值得位子就可以计算得到这个区间的元素个数,依次寻找每个m对应的那个M以及两者之间的元素的个数,找出个数最多的就可以了。
2、为了提高效率,可以将上次循环找到的M所在的位置作为这次二分搜索时的下界,以缩小搜索区间。
3、如果在一个循环中发现序列中最大的那个数都是<=m*p的,那么就可以终止循环了。
4、注意m*p有可能是会溢出int的范围的,所以这里用long型数据进行计算,case 5就是考察这一点的。

代码:
//1085
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
	int n,p;
	scanf("%d%d",&n,&p);
	vector<long>seq;
	seq.resize(n);
	for(int i=0;i<n;++i)
		scanf("%ld",&seq[i]);
	sort(seq.begin(),seq.end());
	int maxcount=0,down=1;
	for(int i=0;i<n;++i)
	{//reuse the answer 'down' can reduce the calculating time
		long max=p*seq[i];
		if(max>=seq[n-1])
		{//if all the element behind i is smaller than max
		 //they all need to be counted and the loop could be stopped
			maxcount=n-i>maxcount?n-i:maxcount;
			break;
		}
		int up=n-1;
		while(up>down)
		{//binary search
			int mid=(up+down)/2;
			if(seq[mid]>max)
				up=mid;
			else if(seq[mid]<max)
				down=mid+1;
			else
			{
				down=mid+1;
				break;
			}
		}
		if(down-i>maxcount)
			maxcount=down-i;
	}
	printf("%d\n",maxcount);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值