HDU 1162Eddy's picture(prim)

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8714    Accepted Submission(s): 4427


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1102  1217  1142  1879  1213 
 给你点的坐标,求把这些点连起来的最短路径,简单的最小生成树,好长时间没写最小生成树prim算法了,有点生疏了。。。。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
double map[110][110],sum;
int n;
void prim()
{
	sum=0.0;
	double dis[2100],min;
	int i,j,k,visit[2100];
	memset(visit,0,sizeof(visit));
	for(i=1;i<=n;i++)
	dis[i]=map[1][i];
	visit[1]=1;
	for(i=2;i<=n;i++)
	{
		min=INF;
		for(j=1;j<=n;j++)
		{
			if(!visit[j]&&min>dis[j])
			{
				min=dis[j];
				k=j;
			}
		}
		sum+=min;
		visit[k]=1;
		for(j=1;j<=n;j++)
		{
			if(!visit[j]&&dis[j]>map[k][j])
			{
				dis[j]=map[k][j];
			}
		}
	}
	printf("%.2lf\n",sum);
}
double distance(double x1,double x2,double y1,double y2)
{
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
	double x[2100],y[2100];
	int i,j;
	while(scanf("%d",&n)!=EOF)
	{
		memset(map,INF,sizeof(map));
		for(i=1;i<=n;i++)
		scanf("%lf%lf",&x[i],&y[i]);
		for(i=1;i<=n;i++)
		for(j=i+1;j<=n;j++)
		{
			map[i][j]=map[j][i]=distance(x[i],x[j],y[i],y[j]);
		}
		prim();
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
疫情居家办公系统管理系统按照操作主体分为管理员和用户。管理员的功能包括办公设备管理、部门信息管理、字典管理、公告信息管理、请假信息管理、签到信息管理、留言管理、外出报备管理、薪资管理、用户管理、公司资料管理、管理员管理。用户的功能等。该系统采用了MySQL数据库,Java语言,Spring Boot框架等技术进行编程实现。 疫情居家办公系统管理系统可以提高疫情居家办公系统信息管理问题的解决效率,优化疫情居家办公系统信息处理流程,保证疫情居家办公系统信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理公告,管理疫情居家办公系统信息,包括外出报备管理,培训管理,签到管理,薪资管理等,可以管理公告。 外出报备管理界面,管理员在外出报备管理界面中可以对界面中显示,可以对外出报备信息的外出报备状态进行查看,可以添加新的外出报备信息等。签到管理界面,管理员在签到管理界面中查看签到种类信息,签到描述信息,新增签到信息等。公告管理界面,管理员在公告管理界面中新增公告,可以删除公告。公告类型管理界面,管理员在公告类型管理界面查看公告的工作状态,可以对公告的数据进行导出,可以添加新公告的信息,可以编辑公告信息,删除公告信息
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值