hdu1162Eddy's picture

 

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11983    Accepted Submission(s): 6017


http://acm.hdu.edu.cn/showproblem.php?pid=1162

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

 

 

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

 

 

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

 

 

Sample Input

3

1.0 1.0

2.0 2.0

2.0 4.0

 

 

Sample Output

3.41

 

题意:连接n个点的最小长度。

思路:经典prim()算法,套模板。

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
#define inf 0x3f3f3f3f
using namespace std;

struct node
{
    double x;
    double y;
}s[105];

int n;
double mapp[105][105];
int vis[105];
double dis[105];

double del(int a,int b)
{
    return sqrt( pow((s[a].x-s[b].x),2)+pow((s[a].y-s[b].y),2) );
}

void prim(int a)
{
    double sum=0;
    vis[a]=1;
    dis[a]=0;
    for(int i=1;i<n;i++)
        dis[i]=mapp[i][a];
    for(int i=0;i<n-1;i++)
    {
        double minn=inf;
        int l;
        for(int j=0;j<n;j++)
        {
            if(!vis[j]&&minn>dis[j])
            {
                minn=dis[j];
                l=j;
            }
        }
        sum+=minn;
        vis[l]=1;
        for(int j=0;j<n;j++)
        {
            if(!vis[j]&&dis[j]>mapp[l][j])
                dis[j]=mapp[l][j];
        }
    }
    cout<<fixed<<setprecision(2)<<sum<<endl;
}

int main()
{
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
            cin>>s[i].x>>s[i].y;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(i==j)
                    mapp[i][j]=mapp[j][i]=0;
                else
                    mapp[i][j]=mapp[j][i]=del(i,j);
            }
        }
        memset(vis,0,sizeof(vis));
        prim(0);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值