HDU 5650 so easy

so easy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 617    Accepted Submission(s): 413


Problem Description
Given an array with
n
integers, assume f(S) as the result of executing xor operation among all the elements of set S . e.g. if S={1,2,3} then f(S)=0 .

your task is: calculate xor of all f(s) , here sS .
 

Input
This problem has multi test cases. First line contains a single integer T(T20) which represents the number of test cases.
For each test case, the first line contains a single integer number n(1n1,000) that represents the size of the given set. then the following line consists of n different integer numbers indicate elements( 109 ) of the given set.
 

Output
For each test case, print a single integer as the answer.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
0 In the sample,$S = \{1, 2, 3\}$, subsets of $S$ are: $\varnothing$, {1}, {2}, {3}, {1, 2}, {1, 3}, {2, 3}, {1, 2, 3}
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5674  5673  5672  5671  5670 
题意:给出N个数的集合,这个集合的所有子集合的元素异或运算后,再将这些子集合的运算结果进行异或运算,问最后结果。
做这道题需要知道的是异或运算满足交换律(a^b)^(c^d)=a^b^c^d  ,并且a^a=0;  a^0=a;只有N为1时,集合中的元素只出现奇数次,其他情况集合中的元素都是出现偶数次,所以此时结果都为0;
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int t,i,j,k,l,m,n;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%d",&n);
    	scanf("%d",&m);
    	for(i=1;i<n;i++)
    	scanf("%d",&k);
    	if(n==1)
    	printf("%d\n",m);
    	else
    	printf("0\n");
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值