LightOJ 1010 Knights in Chessboard(数学规律)




F - Knights in Chessboard
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit

Status





Description

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.



Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.




Input




Input starts with an integer T (≤ 350), denoting the number of test cases.


Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).




Output




For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.




Sample Input




8


1 1


2 1


3 1


4 1


4 2


4 3


4 4


4 5




Sample Output




Case 1: 1


Case 2: 4


Case 3: 9


Case 4: 16


Case 5: 72


Case 6: 96


Case 7: 24


Case 8: 0

给你一个N*N的方格,放K个棋子(棋子是不同的,并且不能同行或者同列)问有多少种方法,利用组合数学的知识A(n,k)*c(n,k)即为所求,不过计算时要注意不能直接算,这样long long 也会超。。。。。。。。。。。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	long long sum1,sum2,num,help;
	int i,j,t,n,m,k;
	int flag=1;
	scanf("%d",&t);
	while(t--)
	{
		sum1=1;
		sum2=1;
		scanf("%d%d",&n,&k);
		printf("Case %d: ",flag++);
		if(k>n)
		{
			printf("0\n");
			continue;
		}
		else
		{
			help=1;
			for(i=n;i>n-k;i--)
			help*=i;
		   for(i=1;i<=k;i++)
		   {
		   		sum1=sum1*(n-i+1)/i;
		   }
		   printf("%lld\n",sum1*help);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值