【LightOJ - 1005 】 Rooks 【组合数学】

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.
.Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.

Input
Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output
For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input
8
1 1
2 1
3 1
4 1
4 2
4 3
4 4
4 5
Sample Output
Case 1: 1
Case 2: 4
Case 3: 9
Case 4: 16
Case 5: 72
Case 6: 96
Case 7: 24
Case 8: 0

上大学以来就没有写过组合数学,先来补充点公示
这里写图片描述

分析 : 首先如果k大于n,一定不可排。其余的 首先n行选出k行C(n, m),再乘上全排列A(n, k)。

代码

#include<cstdio>
#include<iostream> 
using namespace std ;
#define LL long long 
const int MAXN =1e5;
const int MAXM =1e8;
const int inf =0x3f3f3f3f;

/*---------------------*/
LL A(LL n,LL m){
    LL ans=1;
    for(LL i=n-m+1;i<=n;i++) ans*=i;
    return ans;
}
LL C(LL n,LL m){
    LL ans=1;
    for(LL i=n-m+1;i<=n;i++) ans*=i;
    for(LL i=1;i<=m;i++)     ans/=i;
    return ans;
} 
int main(){
    int t ;cin>>t;
    for(int k=1;k<=t;k++){
        LL n,m;cin>>n>>m;
        printf("Case %d: ",k);
        if(m>n) puts("0");
        else  printf("%lld\n",C(n,m)*A(n,m));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值