HDU 5680 zxa and set

zxa and set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 189    Accepted Submission(s): 153


Problem Description
zxa has a set  A={a1,a2,,an} , which has  n  elements and obviously  (2n1)  non-empty subsets.

For each subset  B={b1,b2,,bm}(1mn)  of  A , which has  m  elements, zxa defined its value as  min(b1,b2,,bm) .

zxa is interested to know, assuming that  Sodd  represents the sum of the values of the non-empty sets, in which each set  B  is a subset of  A  and the number of elements in  B  is odd, and  Seven  represents the sum of the values of the non-empty sets, in which each set  B  is a subset of  A  and the number of elements in  B  is even, then what is the value of  |SoddSeven| , can you help him?
 

Input
The first line contains an positive integer  T , represents there are  T  test cases.

For each test case:

The first line contains an positive integer  n , represents the number of the set  A  is  n .

The second line contains  n  distinct positive integers, repersent the elements  a1,a2,,an .

There is a blank between each integer with no other extra space in one line.

1T100,1n30,1ai109
 

Output
For each test case, output in one line a non-negative integer, repersent the value of  |SoddSeven| .
 

Sample Input
  
  
3 1 10 3 1 2 3 4 1 2 3 4
 

Sample Output
  
  
10 3 4
Hint
For the first sample, $A=\{10\}$, which contains one subset $\{10\}$ in which the number of elements is odd, and no subset in which the number of elements is even, therefore $S_{odd}=10,S_{even}=0,|S_{odd}-S_{even}|=10$. For the second sample, $A=\{1,2,3\}$, which contains four subsets $\{1\},\{2\},\{3\},\{1,2,3\}$ in which the number of elements is odd, and three subsets $\{1,2\},\{2,3\},\{1,3\}$ in which the number of elements is even, therefore $S_{odd}=1+2+3+1=7,S_{even}=1+2+1=4,|S_{odd}-S_{even}|=3$.
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5689  5688  5687  5686  5685 
 
给你一个集合,让求这个集合的子集中有奇数个元素的每个子集的中最小的元素之和减去有偶数个元素的每个子集的中最小的元素之和。
刚开始采用直接计算的方法,无论如何就是不对,后来才发现他们的和相互抵消,最后就是集合中的最大值。。。。。。。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int t,n,i,a[11000];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		sort(a,a+n);
		printf("%d\n",a[n-1]);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值