HDU1115 Lifting the Stone (求多边形的重心)

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7142    Accepted Submission(s): 3020


Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 
 

Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 
 

Sample Input
  
  
2 4 5 0 0 5 -5 0 0 -5 4 1 1 11 1 11 11 1 11
 

Sample Output
  
  
0.00 0.00 6.00 6.00
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1392  1086  2108  2150  1348 
 
题意:给出多边形各点的坐标,求该多边形的重心。
思路:计算几何,把多边形分解为多个三角形,该三角形的面积*三角形的重心之和除以多边形的面积即可。如果是凸多边形直接把坐标相加求平均数即可。
#include<stdio.h>
#include<string.h>
double x0,y0,x1,y1,x2,y2,sx,sy,s,sum;
int i,j,k,t,n;
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		scanf("%lf%lf%lf%lf",&x0,&y0,&x1,&y1);
		sx=sy=sum=0;
		for(i=2;i<n;i++)
		{
			scanf("%lf%lf",&x2,&y2);
			s=((x1-x0)*(y2-y0)-(x2-x0)*(y1-y0))*0.5;//求三角形的面积 
			sx+=s*(x0+x1+x2);//重心 
			sy+=s*(y0+y1+y2);
			x1=x2;
			y1=y2;
			sum+=s;//求多边形的面积 
		}
		printf("%.2lf %.2lf\n",sx/(3*sum),sy/(3*sum));
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值