POJ 1017 Packets (贪心)

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51513 Accepted: 17464

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

题意:一个公司出售1*1,2*2,3*3,4*4,5*5,6*6的木板,但这个公司只有6*6的木板,其他类型的木板都是由6*6的分割而来。给出每种木板的需求量,问最少需要多少6*6的木板
思路:从大木板开始分割,
渣渣就是渣渣 委屈,写代码的能力太差,自己模拟的这个过程好复杂,代码写了好长,大神的代码简单又容易理解。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,j,k,l,m,n,sum,a[10],b[]={0,5,3,1};
	while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]),a[1]+a[2]+a[3]+a[4]+a[5]+a[6])
	{
		int ans=0;
		ans+=a[6]+a[5]+a[4]+(a[3]+3)/4;//这个+3和下面的+8,+35好机智 
		int b2=a[4]*5+b[a[3]%4];
		if(b2<a[2])
		ans+=(a[2]-b2+8)/9;
		int b1=ans*36-a[6]*36-a[5]*25-a[4]*16-a[3]*9-a[2]*4;
		if(b1<a[1])
		ans+=(a[1]-b1+35)/36;
		printf("%d\n",ans); 
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值