Light OJ 1245 Harmonic Number (II) (数学)

C - Harmonic Number (II)
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
        res
 = res + n / i;
   
 return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

思路:举个例子吧,如果N为8,则会有4个1 ,2个2,。。。。。。依次类推。

#include<stdio.h>
#define LL long long 
int main()
{
	int t;
	LL n,m,i,l,k,sum,cnt;
	scanf("%d",&t);
	k=1;
	while(t--)
	{
		scanf("%lld",&n);
		if(n==1)
		{
			printf("Case %lld: 1\n",k++);
			continue;
		}
		sum=0;
		cnt=0;
		i=1;
		while(1)
		{
			int a=n/i;
			int b=n/(i+1);
			sum=sum+a+(a-b)*i;
			cnt+=(a-b)+1;
			i++;
			if(cnt==n-1)//如果还剩最后一个,把最后一个加上 
			{
				sum+=n/i;
				break;
			}
			if(b<=i)//此时说明已经加完 
			break;
		}
		printf("Case %d: %lld\n",k++,sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值