HDU 2391 Filthy Rich (简单DP)

Filthy Rich

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3068    Accepted Submission(s): 1361


Problem Description
They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.
 

Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
The maximum amount of gold will always fit in an int.
 

Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.
 

Sample Input
  
  
1 3 4 1 10 8 8 0 0 1 8 0 27 0 4
 

Sample Output
  
  
Scenario #1: 42
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2393  2388  2389  2386  2390 
题意:
在一个矩阵里面,不同的位置放置着不同的黄金。要从左上角出发,只能向下,向右或者向右下走。
求到达右下角时能收集到的最大黄金量是多少?
简单DP;
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1100][1100],map[1010][1010];
int main()
{
	int t,n,m,i,j,k=1,l;
	scanf("%d",&t);
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		memset(map,0,sizeof(map));
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
		for(j=1;j<=m;j++)
		scanf("%d",&map[i][j]);
		for(i=1;i<=n;i++)
		for(j=1;j<=m;j++)
		{
			dp[i][j]=max(dp[i-1][j]+map[i][j],dp[i][j-1]+map[i][j]);
			dp[i][j]=max(dp[i][j],dp[i-1][j-1]+map[i][j]);
		}
		printf("Scenario #%d:\n",k++);
		printf("%d\n",dp[n][m]);
		printf("\n");
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值