HDU 1051 Wooden Sticks (LIS)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18659    Accepted Submission(s): 7638


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1045  1053  1800  1024  3177 
LIS求最长上升子序列。
第一种实现方法。复杂度 O(n^2)
核心代码:
dp[1] = 1;
for (i = 2; i <= n; i++)
{
    temp = 0;
    for (j = 1; j < i; j++)
    {
       if (a[i] > a[j])
       if (temp < dp[j])
       temp = dp[j];
     }
    dp[i] = temp + 1;
}

第二种利用二分。复杂度 O(n*logn)
核心代码:
int binsearch(int x) //找到最小的大于等于它的数
{
   int l = 1, r = len, mid;
   while (l <= r)
   {
       mid = (l + r) >> 1;
       if (d[mid-1] <= x && x < d[mid]) 
	   return mid;
       else if (x > d[mid]) 
	   l = mid + 1;
       else 
	   r = mid - 1;
   }
}
int main()
{
   scanf ("%d", &n);
   for (i = 1; i<= n; i++)
   scanf ("%d", &a[i]);
   memset (d, 0, sizeof (d));
   d[1] = a[1];
   len = 1;
   for (i = 2; i <= n; i++)
   {
      if (a[i] < d[1]) j = 1;
      else if (a[i] > d[len]) 
	  j = ++len;
      else j = binsearch (a[i]);
      d[j] = a[i];
    }
    printf ("%d\n", len);
 return 0;
}
还可以利用lower_bound函数,

lower_bound(a,a+n,k)   二分求ai>=k的ai的最小的指针。

upper_bound(a,a+n,k)  二分求ai>k的ai的最小的指针。

例:可以求长度为n的有序数组a中的k的个数,即为upper_bound(a,a+n,k)-lower_bound(a,a+n,k)。

fill(a,a+n,x);

将数组a0~an位置赋值为x。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
struct node
{
	int h,w;
}t[11000];
bool cmp(node a,node b)
{
	if(a.w!=b.w)
	return a.w<b.w;
	return a.h<b.h;
}
int dp[5010];
int main()
{
	int n,i,j,ans,p;
	scanf("%d",&p);
	while(p--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d %d",&t[i].h,&t[i].w);
		}
		fill(dp,dp+n,INF);
		sort(t,t+n,cmp);
		for(i=n-1;i>=0;i--)
		{
			*lower_bound(dp,dp+n,t[i].h)=t[i].h;
		}
		printf("%d\n",lower_bound(dp,dp+n,INF)-dp);
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值