[HDU1002] A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 252226    Accepted Submission(s): 48598


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1008  1005  1089  1093  1092

题意:大数加法
思路:输入存在字符数组中,倒序赋给整型数组进行加法运算,再转成字符数组输出。
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <iostream>

using namespace std;

char a[1000], b[1000], fin[1000];//a,b 是输入的两个数,fin是结果
int c[1000], d[1000], r[1000];//c,d是将输入的两个数的字符串转换成整型数组

int f(char a)
{
    int r = a-'0';
        return r;//将字符转化成整型
}

char g(int a)
{
    char r = '0' + a;
        return r;//将整型转化成字符
}

int main()
{
    int N;
    scanf("%d", &N);
    for(int j=1; j<=N; j++)
    {
        scanf("%s", a);
        scanf("%s", b);
        int lenl = strlen(a)>strlen(b)?strlen(a):strlen(b);//lenl为两个字符串中最长的那个的长度
        memset(c, 0, sizeof(c));
        memset(d, 0, sizeof(d));
        memset(r, 0, sizeof(r));//字符数组归零

        for(int i=0; i<strlen(a); i++)
        {
            c[strlen(a)-1-i]=f(a[i]);
        }

        for(int i=0; i<strlen(b); i++)
        {
            d[strlen(b)-i-1]=f(b[i]);//将字符数组中的数字倒过来附给整型数组
        }

        for(int i=0; i<lenl; i++)
        {
            r[i]=c[i]+d[i]+r[i];
			if(r[i]>=10)
			{
				r[i]-=10;
				r[i+1]+=1;//加法进位
				if(i == lenl-1){
                    lenl++;//如果最后一位要进位则总长度++
				}
			}
        }
        printf("Case %d:\n", j);
        printf("%s + %s = ", a ,b);

        for(int i = lenl-1; i>=0; i--)
        {
            fin[i] = g(r[i]);
            printf("%c", fin[i]);
        }
        printf("\n");
        if(j != N)
            printf("\n");//两组数据中间要求空行
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值