poj 1003 Hangover

Hangover
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 108979 Accepted: 53117

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source

Mid-Central USA 2001
题意:每个板子伸出上一个板子的长度分别为1/2,1/3,1/4,.............输入伸出的总长度,输出几个板子可以达到这个长度(输出的板子长度大于等于输入的长度)。
思路:先写了一个函数,通过给出的数据算出输出数据的范围,然后开一个数组,将所有板子个数对应的长度存在数组中,再通过二分法找出大于输入数据的数中最小的数。
#include<stdio.h>

double a[100] = {0};

int main()
{
    for(int i=1; i<=276; i++)
    {
        a[i] = a[i-1] + 1.0/(i+1);
    }
    double n;
    int high, low, mid;
    while(scanf("%lf", &n)!=EOF)
    {
        if(n == 0)
            break;
        high = 276, low = 1;
        if(n<0.5)
            high = 1;
        else
        {
            while(high > low)
            {
                mid = (high + low)/2;
                if(a[mid] > n)
                    high = mid;
                else if(a[mid] < n)
                    low = mid;
                else
                    break;
                if(high - low == 1)
                    break;
            }
        }

        printf("%d card(s)\n", high);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值