HDU 1020 at Sun

I - O
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output

For each test case, output the encoded string in a line.
 

Sample Input

    
    
2 ABC ABBCCC
 

Sample Output

  
  
ABC A2B3C 题意:给定一串只有大写英文字母的字符串,统计这个字符串中有几个相同的字母,数字'1'省略。 思路:若后面的字母与前面的字母相同的该整形数组中的字母++,否则计数数组下标++;
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

char a[10004], cun[10004];
int jishu[1004]={0};

int main()
{
    int N, k = 0;
    scanf("%d", &N);
    for(int j = 1; j <= N; j++)
    {
        scanf("%s", a);
        k=0;
        for(int i=0;i<strlen(a);i++)
        {
            if(a[i] == a[i+1])
            {
                jishu[k]++;//如果前一字母与后一字母相同,则计数数组++;
            }
            else
            {
                cun[k] = a[i];
                jishu[k]++;
                k++;//否则计数数组下标++;
            }
        }
        jishu[k]++;
        for(int i=0; i<k; i++)
        {

            if(jishu[i] != 1)
            {
                printf("%d", jishu[i]);
            }
            printf("%c",cun[i]);
        }
        printf("\n");
        memset(a, 0, sizeof(a));
        memset(jishu, 0, sizeof(jishu));
        memset(cun, 0, sizeof(cun));//重置3个数组;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值