【冀宝er要逆袭之第一次排位赛】

这次排位赛, 一共A出了三道题,果然还是很菜,冀宝er要继续努力。
这里写图片描述

ZOJ 2965-A- Accurately Say “CocaCola”!
问题描述

In a party held by CocaCola company, several students stand in a circle and play a game.

One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, …) or contains the digit ‘7’ (e.g. 7, 17, 27, …), he shall say “CocaCola” instead of the number itself.

For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say “CocaCola” because 27 contains the digit ‘7’. The fourth one should say “CocaCola” too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.

During a game, you may hear a consecutive of p “CocaCola”s. So what is the minimum number that can make this situation happen?

For example p = 2, that means there are a consecutive of 2 “CocaCola”s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be followed by T consecutive test cases.

There is only one line for each case. The line contains only one integer p (1 <= p <= 99).

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p “CocaCola”s stands for.

Sample Input

2
2
3

Sample Output

27
70

这道题第一名十分钟就A了,我想了半天,最后才发现其实只要把7的倍数全都打印出来,在700之前找就行,因为从700开始就会开始连续的100个coca,打印之后在7的倍数中和接下来的数字中含有数字7就可以构成答案
这里写图片描述
发现270-280正好可以构成11次COCA,第12个开始就只能从700开始,所以我们可以直接写出程序

#include <iostream>
using namespace std;
int main(int argc, char *argv[])
{
    int i,j;
    cin>>j; 
    while(j--)
    {
    cin>>i;
    if(i==1)cout<<7<<endl;
    else if(i==2) cout<<27<<endl;
    else if(i>=3&&i<=10)cout<<70<<endl;
    else if(i==11) cout<<270<<endl;
    else cout<<700<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值