poj3187(next_permutation实现全排列+杨辉三角)

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5752 Accepted: 3335

Description
FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4

  4   3   6

    7   9

     16

Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

Input
Line 1: Two space-separated integers: N and the final sum.

Output
Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically(辞典编纂的) least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4
图1
图2
题解:这是一个倒的杨辉三角,第i个数前面的系数为C(n-1,i-1),所以sum=a1*C(n-1,0)+a2*C(n-1,1)+……+ai*C(n-1,i-1)+……然后运用next_permutation进行全排列,加上限制条件就OK了

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int comb(int n,int m){//求组合数C(n,m) ,手写的
    if(m==0||n==m)return 1;
    if(m==1)return n;
    int i,sum1=1,sum2=1;
    for(i=1;i<=m;i++)sum1*=i;
    for(i=n-m+1;i<=n;i++)sum2*=i;
    return sum2/sum1;
}
int main(){
    int n,sum,i,cnt;
    int a[20],s[20];
    while(scanf("%d %d",&n,&sum)!=EOF){
        for(i=0;i<n;i++){
            if(i>(n-1)/2){
                s[i]=s[n-1-i];
            }
            else{
                s[i]=comb(n-1,i);
            }
        }

        for(i=0;i<n;i++)a[i]=i+1;
        do{
            cnt=0;
            for(i=0;i<n;i++){
                cnt+=a[i]*s[i];
            }
            if(cnt==sum){
                for(i=0;i<n-1;i++)printf("%d ",a[i]);
                printf("%d\n",a[n-1]);
                break;
            }
        }while(next_permutation(a,a+n));

    }   
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值