poj1731(dfs实现全排列)

该博客探讨了如何使用深度优先搜索(DFS)算法来解决全排列问题,具体场景是商店经理根据商品标签首字母对仓库进行排序,并需要按订单处理货物。文章提供了输入输出示例,并解释了利用DFS策略遍历所有可能的仓库访问顺序。
摘要由CSDN通过智能技术生成

Orders
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10087 Accepted: 6109

Description
The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled(贴上标签的) with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day.

Input
Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn’t exceed 200.

Output
Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet – the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes(兆字节).

Sample Input

bbjd

Sample Output

bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb
先升序排序,然后从开始往下找,找之前没有找过的,然后取,取完之后往回退一步,继续往下找,一直遍历所有情况为止。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stdlib.h>
#include<cstring>
using namespace std;
int vis[202],cnt;
char in[202],out[202];
int cmp(char a,char b){
    return a<b;
}
void dfs(int len){
    int i;
    char c='\0';
    if(len==cnt){
        out[cnt]='\0';
        printf("%s\n",out);
    }
    for(i=0;i<cnt;i++){
        if(!vis[i]&&in[i]!=c){
            vis[i]=1;
            out[len]=in[i];
            c=in[i];
            dfs(len+1);
            vis[i]=0;
        }
    }
}
int main(){
    while(scanf("%s",in)!=EOF){
        sort(in,in+strlen(in),cmp);
        memset(vis,0,sizeof(vis));
        cnt=strlen(in);
        dfs(0);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值